Nissan Frontier Forums

Affiliate Site : Nissan Titan Forums
  Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp  Photo GalleryPhoto Gallery
  RegisterRegister  LoginLogin

Sponsored Links

Problems / Technical
 Nissan Frontier Forums : Problems / Technical
Subject Topic: Thermal control amplifier (ac issue) (Topic Closed Topic Closed) Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
bcaughhorn
Groupie
Groupie
Avatar

Joined: Aug 27 2010
Online Status: Offline
Posts: 52

Member's Gallery:
View Gallery




Location:
U.S. - Alabama
Posted: Sep 07 2010 at 5:17am | IP Logged  

no that is not the same as mine either
Back to Top View bcaughhorn's Profile Search for other posts by bcaughhorn
 
meyerdel
Newbie
Newbie


Joined: Apr 23 2010
Online Status: Offline
Posts: 12

Member's Gallery:
View Gallery
Posted: Sep 07 2010 at 12:53pm | IP Logged  

Well, I guess there are at least 3 types then. All summer long here in AZ, my AC worked more than it didn't work, and now summer is about done. I figure I have 4-5 months to get this AC problem worked out. I might just take the $117 chance and see what happens.
Back to Top View meyerdel's Profile Search for other posts by meyerdel
 
lanai1
Newbie
Newbie


Joined: Sep 18 2010
Online Status: Offline
Posts: 1

Member's Gallery:
View Gallery


Location:
U.S. - Hawaii
Posted: Sep 18 2010 at 6:55pm | IP Logged  

Aloha All, registered just to inform all of a successfull TCA replacement. My wife's 02 Xterra SE Supercharged V6 Automatic , A/C quit, living here on the outer island of Lanai you don't have many options but to do repairs yourself or send it off island for repairs which is very spendy. Anyway delaying ( for like a year) what I thought would be a time consuming and expensive repair I decided to dig in and start my research on my system which led me here. Well first thing I did was determine if it was an intermittent condition and after just turning on and off A/C for about 10 minutes I was able to actually get it to turn on and blow cold air a few times. So without really any other diagnosis other than a visual check of all components I found the part online and ordered it from http://www.texasnissan.com. Ended up costing about $40 (everything costs more here due to shipping). It took about 1 1/2 hours to install, yeah I thought I would be smart and take some of the dash/console plastic off to gain better access, wrong don't do this, gained no better access and wasted an hour! it's just tight quarters and needs patience and small hands if possible. Well mahalo to all for info and pix!!

Back to Top View lanai1's Profile Search for other posts by lanai1
 
meyerdel
Newbie
Newbie


Joined: Apr 23 2010
Online Status: Offline
Posts: 12

Member's Gallery:
View Gallery
Posted: Sep 18 2010 at 10:03pm | IP Logged  

Hi lanai1, glad you got yours fixed. Try getting a TCA out of a Sentra! I guess I'm still not totally conviced it is the TCA that is the problem. The same day the AC started acting up, was the same day that a fuel pump relay went bad. I always thought there was a connection. Mechanic didn't think so.
Back to Top View meyerdel's Profile Search for other posts by meyerdel
 
johnsnook
Newbie
Newbie
Avatar

Joined: Sep 24 2010
Online Status: Offline
Posts: 1

Member's Gallery:
View Gallery


Location:
U.S. - Florida
Posted: Sep 25 2010 at 12:03am | IP Logged  

I am having the same problem with my 2001 Frontier ac not working sometimes. While I think it is the TCA, I have another problem that may be related. Two days ago I went to the car wash and while in the wash, suffering from the ac blowing hot air, when the soap was applied I started getting soap bubbles blowing out of the center dash vents. Does anyone know what the problem could be ?

__________________
john
Back to Top View johnsnook's Profile Search for other posts by johnsnook
 
brandonmillsap
Newbie
Newbie


Joined: Feb 03 2011
Online Status: Offline
Posts: 8

Member's Gallery:
View Gallery
Posted: Feb 04 2011 at 11:45pm | IP Logged  

I think it has something to do with the A/C amplifier. A replacement needs to be done soon.



_______________

Keep it flowing!

93 Formula Mods: 383, LE2 Heads/Intake, 226/230 cam, 52MM TB, Magnaflow cat back, Brake Disc LT headers, CAI, SFC, Strut Brace, Adj LCA, Adj Panhard, Oil Pan Gasket Set Relocated Torque Arm, Progressive Rate Springs Short Throw Shifter
Back to Top View brandonmillsap's Profile Search for other posts by brandonmillsap
 
snstcruise
Newbie
Newbie


Joined: Jan 12 2011
Online Status: Offline
Posts: 8

Member's Gallery:
View Gallery
Posted: Mar 06 2011 at 6:52pm | IP Logged  

Hey all I replaced my TCA after my system exhibited all the symptoms on this post and I still have a warm cold ac problem. I noticed that my system also has a small leak at the low side valve.  I noticed refrigerant ooze at the valve.  The pressure charge lasts about 2 hours before it goes low though.  Usually between 40 and 60 psi.  During the time it has this charge it still goes from warm to cold intermittenly.  Could this leaky valve be the reason why?  How much does this valve cost and is it possibly a do it yourself job?
Back to Top View snstcruise's Profile Search for other posts by snstcruise
 
wxwzrd
Newbie
Newbie
Avatar

Joined: Apr 01 2011
Online Status: Offline
Posts: 3

Member's Gallery:
View Gallery
Posted: Apr 01 2011 at 10:11pm | IP Logged  

I have a 2010 SE 4x4 I bought July of last year.  At the end of a 2-hour trip later in the summer, the A/C wouldn't blow cold air.  After letting the truck sit for a while, it would work again.  I stumbled upon this forum and didn't realize how common the TCA problem was.  I have a thermistor (which does the same thing) and ordered a new one.  Cured the problem and A/C blows cold.  I changed it myself in about 20 minutes--the design makes it pretty easy.  Just had to remove the lower side trim on the passenger side, pulled the glove box and the map box.  The thermistor was in plain sight and it took literally a minute to pull it and insert the new one.  At least the newer design seems to make it easier to swap it out.  Price of the new part was $50--I didn't want to waste time at the dealer to troubleshoot even though the truck is still under warranty.
Back to Top View wxwzrd's Profile Search for other posts by wxwzrd
 
meyerdel
Newbie
Newbie


Joined: Apr 23 2010
Online Status: Offline
Posts: 12

Member's Gallery:
View Gallery
Posted: Apr 02 2011 at 4:11am | IP Logged  

Well, I've got to say that yours is the newest vehicle that I've heard needing replaced. I can't believe how fast this winter went! Yesterday, here in Arizona, we hit the mid 90's already, and here I am again, just like I started last summer, with the AC coming and going.

I could buy and replace every part that has been suggested that "might" be the problem, and still come out ahead compared to taking it in the shop.

I ordered the ac relay yesterday, and Mon I'm biting the bullet for the amplifier. I'm curious, you said you paid $50 for the thermister type amp. Was what you got a tube that was attached to a circut board with a wire?

Back to Top View meyerdel's Profile Search for other posts by meyerdel
 
wxwzrd
Newbie
Newbie
Avatar

Joined: Apr 01 2011
Online Status: Offline
Posts: 3

Member's Gallery:
View Gallery
Posted: Apr 02 2011 at 8:13pm | IP Logged  

Meyerdel--I was rather surprised, too.  Could have been a manufacturing defect--my first guess is that the thermister had out of tolerance resistance based on the temperature and the computer had trouble making the adjustments.  I also went ahead and changed the cabin filters to make sure plenty of air was flowing through.  The thermister is a pretty basic part.  Here is a link to show you what it looks like--a bit different than the older designs through 2004.

http://www.courtesyparts.com/27723n-sensor-assy-thermister-f rontier-d40-2005-2008-cyl-auto-air-cond-2009-2010-auto-air-c ond-2010-p-612883.html

Hope that helps.

http://www.courtesyparts.com/27723n-sensor-assy-thermister-f %20rontier-d40-2005-2008-cyl-auto-air-cond-2009-2010-auto-ai r-c%20ond-2010-p-612883.html

lakota

Back to Top View wxwzrd's Profile Search for other posts by wxwzrd
 

<< Prev Page of 12 Next >>
  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Sponsors

Powered by Web Wiz Forums version 7.92
Copyright ©2001-2004 Web Wiz Guide
A Vebro Solutions Venture
Hosted by Vebro Hosts
Need a vacation? Find our more about a Hawaii Vacation or get Hawaii insider tips!