Nissan Frontier Forums

Affiliate Site : Nissan Titan Forums
  Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp  Photo GalleryPhoto Gallery
  RegisterRegister  LoginLogin

Sponsored Links

Problems / Technical
 Nissan Frontier Forums : Problems / Technical
Subject Topic: help... stuck Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
stevesxm
Newbie
Newbie


Joined: Jul 06 2017
Online Status: Offline
Posts: 4

Member's Gallery:
View Gallery




Location:
U.S. - Florida
Posted: Aug 08 2018 at 7:10am | IP Logged Quote stevesxm

have 04 frontier 4 cyl , manual trans.   drove to work this am ... everything fine.   came out to go somewhere, no lights on the dash at all and no start or crank. battery checks fine, master 80 amp link in the fuse box is fine and all fuses and links in there are fine. is thereanother fusiblelink hiding somewhere or something ? im notgetting home unless I can fix this.

thx
Back to Top View stevesxm's Profile Search for other posts by stevesxm
 
lakota
Moderator Group
Moderator Group
Avatar
Nissan Frontier Forums Moderator

Joined: Feb 14 2005
Online Status: Offline
Posts: 1816

Member's Gallery:
View Gallery


Location:
U.S. - Texas
Posted: Aug 08 2018 at 1:45pm | IP Logged Quote lakota

..

If all electrical is dead start with electrical connectors. Start at the battery and don't forget anything electrical has to have a ground!

Good luck.. Don S..


__________________
PLEASE >>> A SIG similar to mine can be VERY HELPFUL to all the members!
'99 4x4 3.3 Frontier Se KC Auto, 48,000 miles
'76 4x4 401 Wagoneer QT
'04 FWD 1.8 Sentra '08 FWD 2.4 Camry LE
Fort Worth
Back to Top View lakota's Profile Search for other posts by lakota Visit lakota's Homepage
 
stevesxm
Newbie
Newbie


Joined: Jul 06 2017
Online Status: Offline
Posts: 4

Member's Gallery:
View Gallery


Location:
U.S. - Florida
Posted: Aug 08 2018 at 2:13pm | IP Logged Quote stevesxm

everything not dead. windows go up and down, radio works. all grounds checked. everything IN the fuse box is live but somewhere somehow there is no primary voltage getting to the dash/ignition/ starter circuit. are there any other fuseable links anywhere else other than the fuse box ?
Back to Top View stevesxm's Profile Search for other posts by stevesxm
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Sponsors

Powered by Web Wiz Forums version 7.92
Copyright ©2001-2004 Web Wiz Guide
A Vebro Solutions Venture
Hosted by Vebro Hosts
Need a vacation? Find our more about a Hawaii Vacation or get Hawaii insider tips!